Pull text with calculation



  • Kareem Ahmed Asfour


    I think i got your point.

    you can create a relationship field in your new app. ( referenced to master app ) .

    then you can create calculation field. @all of software version+" ";


    if you need any help just pm me kareem-asfour@hotmail.com

    Comment actions Permalink
  • Jeremy Caunt

    Thanks for your reply, kareem, 

    I've tried adding the calculation as suggested and get the following response:

    Preview: invalid value null (null): must be a string.

    Do you know what I might be doing wrong?

    Thanks again.

    Comment actions Permalink
  • Jeremy Caunt


    I have also tried: 

    @All of Software.join()

    but this returns the same error - Preview: invalid value null (null): must be a string.

    Any thoughts of what I might be doing wrong?

    Comment actions Permalink
  • Rainer Grabowski

    Hi Jeremy, 

    the preview notification simply says that nothing was found. Either the called field is empty or no item is related to the item where you are in the calculation field. Try it in an item where you are sure it's related and where the related item has a value in that field.
    Also: If you have a relationship from Master to the apps and relationship from the other app to the Master too you have 2 tokens for @all of Software Version - be sure to pick the right one, incoming or outgoing. 
    If the problem can't be solved please share a screenshot of the calculation.


    Comment actions Permalink
  • Jeremy Caunt

    Thanks for your help guys, still not getting it quite right.

    I've had partial success in pulling a number into one calculation field, however, I'm not doing something right to get text across.

    Here are a couple of screenshots showing two versions of the calculation fields and one showing the result.

    In each screenshot, the top calculation (Version No.) is working correctly and pulling the correct number across.

    However, I can't get text to come across into Description. Example 1 and example 2 are different calculations I've tried to do this. I'm hoping it's something simple I'm doing/missing.

    I've tried deleting the calculation field and making a new one and have looked through the forum for the code but can't find it.

    Any help, much appreciated.


    Comment actions Permalink
  • Riky Silverio

    Did anyone solve this issue? I am having the same problem at the moment.

    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk