Calculation Field not working with string



  • Emili Girones


    @All of RUT Empresa.join() != null ? (@All of RUT Empresa.join()) : (null)

    Comment actions Permalink
  • Vicente Aranda

    Hi Emili! Thanks for the help!

    I'm afraid it didn't work though:

    The result of both calc fields is a blank space:

    Comment actions Permalink
  • Rainer Grabowski

    Hi Vincente,

    if a Client item with a filled field RUT Empresa is related to the item in the other app where you try to create the calculation @All of RUT Empresa.toString() should work. 

    My suspicion is either
    A) that you have in Clients also a relationship field that points to the other app, but it is empty. When you now enter @All of RUT Empresa in the drop down you see 4 tokens for it: 
    Incoming with nulls
    Outgoing with nulls

    You need to pick the Outgoing token (= the relationship from the other app to the Clients app = field Cliente a Facturar)

    B) that the calculation field (better: the sandbox in the background)  sees that there is a number in RUT Empresa and tries to save the calc field as a number field. Please check the field settings (by clicking the little triangle on the left side of the brick) if it is type number or text. You can also try this: 
    Create a new calc field, enter
    Save the template. Now it is text type. 
    Then enter @All of RUT Empresa.toString()
    If you still get the error try to pull another field from the Client app, e.g @All of Status.toString().
    If that works and the field RUT Empresa is filled, then there's a problem with the text field. You should add another field, enter the same text as in RUT Empresa and check if that text is shown in the calc field. If so, use that field (copy all data from RUT Empresa into the new text field with a flow). If not, enter another text like "abc" and check if it is shown. 
    If even the Status field and the new text field aren't shown in the calc field then something with the relationship isn't correct. Add a new relationship field and enter the items again. 


    Comment actions Permalink
  • Vicente Aranda

    Thanks Rainer!

    I tried erasing the old relationship field and creating a new one, which worked fine until I changed the visibility of that field:

    I created a new relationship field to show the current client as a visible field (so I could test the calc field using different "Client items"). It worked fine so I turned it into an "always hidden" field and then the calculation stopped working.

    Has anyone else had such a strange issue?

    Comment actions Permalink
  • Rainer Grabowski

    That sounds weird. I can't reproduce it. What exactly do you mean by: then the calculation stopped working?
    Maybe you should contact the Podio support so that they can check if there's something broken in the app. 

    Comment actions Permalink
  • Vicente Aranda

    It is weird indeed. I haven't be able to reproduce it anywhere else neither. It looks like the app itself has a problem.

    The calculation, after I changed the relationship field's visibility, returned nothing.

    As you suggest, I think I'll contact Podio support.

    Thanks for the help!
    I'll try to comment here the solution (if there's any)!

    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk