"The Result is not a valid number" when trying to Calculate Price per square foot

Comments

6 comments

  • Rainer Grabowski

    "Not a valid number" can also appear if the factor (your number field) is empty. 

    @Property Size Sqft. != null ? @Seller's Price /@Property Size Sqft. : ""

    If number field has no value it doesn't run the calculation and shows nothing in the calc field. 

    Rainer

    1
    Comment actions Permalink
  • Hamid

    Hi Mickael,

    create a new calculation field and retry 

    0
    Comment actions Permalink
  • Rainer Grabowski

    hi Michael,

    sometimes you have to "persuade" the calculation field ot accept something. Try

    (@Seller's Price / @Property Size (Sq. Ft.)) || 123 

    Is @Property Size (Sq. Ft.) a number field or a number in a text field?

    Rainer

     

     

    0
    Comment actions Permalink
  • Michael Laniak

    Thank you for offering the help but it still is not working. Here are the field types.

    1). @Seller's Price = (Money Field)
    2). @Property Size Sqft. = (Number Field)

    I would like to find a solution where the field types stay as they are and not switching the @Seller's Price field to a number if possible.

    0
    Comment actions Permalink
  • Hamid

     

    "$" + (@Seller's Price / @Property Size (Sq. Ft.)).toFixed(2) || 123 

     

     

    0
    Comment actions Permalink
  • Michael Laniak

    Rainer thank you!  That was the issue.  And now it shows properly in the calculation field for.  :-)

    @Property Size SqFt. != null ? @Seller's Price /@Property Size SqFt. : ""

     

     

    0
    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk