Post

2 followers Follow
0
Avatar

PHP V. 7 for Podio API

Is Podio API compatible with PHP V. 7.0.3?

Mark Cannon

Please sign in to leave a comment.

3 comments

0
Avatar

Hi Mark,

I assume you are referring to our SDK for PHP.

In order to use our SDK you need PHP 5.3+ with curl and openssl extensions enabled. There are no external dependencies.

Hope that helps.

Best,
Domenico

Domenico Matteo 0 votes
0
Avatar

Hi Domenico,

I had read that in the podio SDK documentation. The question I have is with how it is written. Does that mean php version 5.(3+) or (5.3)+. In other words does it need to be a version 5 (i.e., 5.(3+)) or can it be the version 7 (which would be okay if it was (5.3)+). Can you clear that up for me?

I'm not sure if there were features removed from php version 7 that were needed for the podio SDK.

Thanks,

-Mark

Mark Cannon 0 votes
0
Avatar

Hi Mark,

I've run our test suite on PHP 7 and everything passed (see https://travis-ci.org/podio/podio-php/builds/112884277).

Unfortunately we don't use the PHP client internally, so I can't really tell you with the utmost certainty that it will work, but the fact that the test suite is passing is a very likely indicator that there are no problems with PHP 7.

Best,
Domenico

Domenico Matteo 0 votes