Post

4 followers Follow
0
Avatar

Podio webforms not working

Hi my podio webforms dont want to work any more , what exactly do I need to update in them , because I customised the code.

Rudolph de Kock

Official comment

Avatar

Dear all,

we're in a transition phase between the new and old webforms, so please bear with us :)

We introduced a security check that should have been in place long ago, which ensures that the webform is being submitted from a trusted source and that it belongs to Podio.
If you're curios, you can search for CSRF protection.

Specifically, the webforms can now only be used with their "Podio link" OR with the official embed script.
Any other usage that worked before will not work anymore.

This includes, but it's not limited to:
* Sending a POST request with the correct fields and address via custom HTML forms
* Sending a POST request with the correct fields and address via mobile

For all these "custom" needs, you are advised to use the API directly


Regarding the prefilled fields, we are aware of the situation and they will be restored ASAP.


I hope to have addressed your questions throughly and thanks in advance for your understanding,

Domenico Matteo

Please sign in to leave a comment.

7 comments

0
Avatar

I know that Podio do an update. I also have trouble with prefilling field...

Jean-Claude Massé 0 votes
0
Avatar

I figured out my problem , because I customized the form I dont use the generated code , I host it on my own domain , and when I submit the form I sent it to /webforms/***/**** . So I checked the new code when I generate an old form & they changed it to /webforms_old/*****/**** . So I just updated the url the form is posting to

<form accept-charset="UTF-8" action="/webforms_old/******/****"

Rudolph de Kock 0 votes
0
Avatar

I do it too and it's work for me. From what i know, Podio will continue upgrading webform until next wednesday.

Jean-Claude Massé 0 votes
0
Avatar

I also have trouble with prefilling field.
I would like to know when the problem will be solved?

Иванов Станислав 0 votes
0
Avatar

Hi,
for prefilled fields, it's work... but you have to change the way you do it before. It's not the id number of field but the id text of field. Before it's was something like field_11111111, but now is fieldscourriel

Jean-Claude Massé 0 votes