"Bad Request" Error

Answered

Comments

4 comments

  • Andreas Haugstrup Pedersen

    Can you share some more information on the error? Such as exactly what you're sending and the entire http response? Otherwise it's hard to help.

    There is only one version of the Podio API. Are you talking about an old version of a client library?

    /Andreas

    0
    Comment actions Permalink
  • Shahil Sham

    Hello Andreas,

    Yes we are using an old version of client library.

    Here is the error log:

    [error] [client 27.251.161.87] GET /app/space/1161450/? HTTP/1.1\r\nUser-Agent: Podio PHP Client/2.0\r\nHost: api.podio.com\r\nAccept: application/json\r\nContent-type: application/x-www-form-urlencoded\r\nAuthorization: OAuth2 fc8e67b4d53848e48a44f7f1fb746a7f\r\nContent-length: 0\r\n\r\n

    [error] [client 27.251.161.87] [PODIO] 0 GET /app/space/469307/?

    [error] [client 27.251.161.87] [PODIO] Reponse: <html>\r\n<head><title>400 Bad Request</title></head>\r\n<body bgcolor="white">\r\n<center><h1>400 Bad Request</h1></center>\r\n<hr><center>nginx</center>\r\n</body>\r\n</html>\r\n

    [error] [client 27.251.161.87] GET /app/space/469307/? HTTP/1.1\r\nUser-Agent: Podio PHP Client/2.0\r\nHost: api.podio.com\r\nAccept: application/json\r\nContent-type: application/x-www-form-urlencoded\r\nAuthorization: OAuth2 fc8e67b4d53848e48a44f7f1fb746a7f\r\nContent-length: 0\r\n\r\n

     

    Does that make any sense? :)

    0
    Comment actions Permalink
  • Andreas Haugstrup Pedersen

    This is most likely fixed in the latest version of podio-php ( https://github.com/podio/podio-php/commit/8930425240917d7ae788dcbb9b9220ddd5be6ef8 ) and I suggest you just upgrade. There are many many improvements.

    /Andreas

    0
    Comment actions Permalink
  • Shahil Sham

    Thanks Andreas for pointing us in the right direction.

    0
    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk