Beginner, i don't understand my problem

Answered

Comments

5 comments

  • Andreas Haugstrup Pedersen

    Hi Vincent,

    The code under "My Code" is using the previous version of the PHP client. The code example from the documentation is using the current version of the PHP client. The two are not compatible.

    Your best cause of action is to update your own code to the current version of the PHP client and update your PHP client from https://github.com/podio/podio-php

    There won't be backwards incompatibility like this going forward, but I did have to make major changes when doing the current version. The future updates will be incremental in nature.

    /Andreas

    0
    Comment actions Permalink
  • Vincent BARBEROT

    All right. I didn't sure it was a version problem. Nevertheless, I have still a problem because of the lib :

     

    Fatal error: Class 'PodioResponse' not found in /homez.139/networkv/www/podio/lib/PodioAPI.php on line 160

    My structure :

    www/podio/config.podio

    www/podio/lib

    www/podio/username-password-auth.php

     

    My code :

    // Include the config file and the Podio library

      require_once 'config.podio';

      require_once 'lib/PodioAPI.php';

    0
    Comment actions Permalink
  • Andreas Haugstrup Pedersen

    You are requiring the wrong file. Instead of requiring 'lib/PodioAPI.php just require 'PodioAPI.php'

    0
    Comment actions Permalink
  • Vincent BARBEROT

    Thank you very much. In fact, I don't have the good version (PHP 5.2), so I can't continue for the moment. What a pity !

    0
    Comment actions Permalink
  • Andreas Haugstrup Pedersen

    Hi Vincent,

    I will strongly encourage you to upgrade your PHP version. 5.2 reached end-of-life in 2010. You are missing out on great features in PHP 5.3 and 5.4 and exposing yourself to potential security issues by using an outdated version of PHP.

    /Andreas

    0
    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk